Locations of visitors to this page Perfect dream will never let you sleep in peace...untill you make it real: April 2011

Saturday, April 30, 2011

BGP MED Multi Exit Discriminator

    ----->R3----->
R4                             R1
    ----->R2----->

R1 is company router is AS 100 and other routers are ISP routers with AS 200

In this scenario, lets say R1 is advertising 2 networks. 10.1.0.0 and 10.2.0.0. With all defaults, R4 would choose R2  (2.2.2.2 is specified as router ID of R2 and 3.3.3.3 for R3) to reach both networks.  check the below link for best path selection.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094431.shtml

Now with MED you can let
R4 to choose R3 to reach R1 for 10.1.0.0
&
R4 to choose R2 to reach R1 for 10.2.0.0

on router R1


router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.1.0.0 mask 255.255.0.0
 network 10.2.0.0 mask 255.255.0.0
 neighbor 192.168.20.2 remote-as 200
 neighbor 192.168.20.2 route-map sMEDR2 out
 neighbor 192.168.30.2 remote-as 200
 neighbor 192.168.30.2 route-map sMEDR3 out
 no auto-summary
!
access-list 2 permit 10.2.0.0 0.0.255.255
<create access list for 10.1.0.0>
!
route-map sMEDR2 permit 10
 match ip address 2
 set metric 100
!
route-map sMEDR2 permit 20
 match ip address 1
 set metric 200
!
<create further route maps and set metric as 100>




Sunday, April 10, 2011

ospf commands

sh ip protocol


Router#sh ip pro
Routing Protocol is "ospf 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.1.0.0 0.0.255.255 area 100
    10.0.0.0 0.255.255.255 area 100
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.2.2.2              110      00:00:19
  Distance: (default is 110)


sh ip ospf  or sh ip ospf process ID --->shows how many times SPF has been calculated. More the number lesser the stability of the network.


Router#sh ip ospf                                                  
 Routing Process "ospf 100" with ID 1.1.1.1
 Start time: 00:01:25.328, Time elapsed: 00:41:49.764
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
    Area 100
        Number of interfaces in this area is 2 (1 loopback)
        Area has no authentication
        SPF algorithm last executed 00:01:20.384 ago
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x01587C
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0



sh ip ospf database --> shows number of connected neighbors discovered by hello packets


Router#sh ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 100)

                Router Link States (Area 100)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         169         0x80000004 0x0025C1 2
2.2.2.2         2.2.2.2         168         0x80000003 0x003B9F 2

                Net Link States (Area 100)

Link ID         ADV Router      Age         Seq#       Checksum
10.10.1.1       1.1.1.1         169         0x80000001 0x00F71C



sh ip ospf interface--->

 Router#sh ip ospf interface f0/0
FastEthernet0/0 is up, line protocol is up --->state of the link
  Internet Address 10.10.1.1/24, Area 100 --->interface IP and area in which the interface is
  Process ID 100, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1----> cost of the link
  Transmit Delay is 1 sec, State DR, Priority 1 -->TD is amount of time taken in sending update to the neighbor, state is DR,BDR,Waiting,DROther. Priority is another parameter in hello packet of OPSF
  Designated Router (ID) 1.1.1.1, Interface address 10.10.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5--->shows hello packet varialbles
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

Sh ip ospf neigh


Router#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/BDR        00:00:33    10.10.1.2       FastEthernet0/0

it shows about neighbor states and physical interface with which the neigbor is connected


Router#sh ip ospf neighbor 2.2.2.2
 Neighbor 2.2.2.2, interface address 10.10.1.2
    In the area 100 via interface FastEthernet0/0
    Neighbor priority is 1, State is FULL, 6 state changes  -----> INIT, 2 WAY, EXSTART, EXCHANGE, LOADING, FULL,DOWN,ATTEMPT
    DR is 10.10.1.1 BDR is 10.10.1.2
    Options is 0x52
    LLS Options is 0x1 (LR)
    Dead timer due in 00:00:35
    Neighbor is up for 00:12:22
    Index 1/1, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec



Saturday, April 9, 2011

OSPF LSA types


  • LSA 1 (Router LSA)
Generated by all routers in an area to describe their directly attached links (Intra-area routes). These do not leave the area.
  • LSA 2 (Network LSA)
Generated by the DR of a broadcast or Nonbroadcast segment to describe the neighbors connected to the segment. These do not leave the area.
  • LSA 3 (Summary LSA)
Generated by the ABR to describe a route to neighbors outside the area. (Inter-area routes)
  • LSA 4 (Summary LSA)
Generated by the ABR to describe a route to an ASBR to neighbors outside the area.
  • LSA 5 (External LSA)
Generated by ASBR to describe routes redistributed into the area. These routes appear as E1 or E2 in the routing table. E2 (default) uses a static cost throughout the OSPF domain as it only takes the cost into account that is reported at redistribution. E1 uses a cumulative cost of the cost reported into the OSPF domain at redistribution plus the local cost to the ASBR.
  • LSA 6 (Multicast LSA)
Not supported on Cisco routers.
  • LSA 7 (NSSA External LSA)
Generated by an ASBR inside a NSSA to describe routes redistributed into the NSSA. LSA 7 is translated into LSA 5 as it leaves the NSSA. These routes appear as N1 or N2 in the ip routing table inside the NSSA. Much like LSA 5, N2 is a static cost while N1 is a cumulative cost that includes the cost upto the ASBR.

Friday, April 8, 2011

EIGRP interface BW command


EIGRP bandwidth control over Serial Subinterfaces

Hi All,

Lets consider a t1 link on a routers serial interface. The link is having 4 PVC. 2 are on s1/0.1 and one on s1/0.2 and one more on the s1/0.3. If i issue no command of bandwidth control, then how the EIGRP is going to use this BW for each PVC on serial S1/0.1 and on S1/0.2 or S1/0.3.

I could understand under defaults, each interface would have around (1544/3=) 515 Kbps. But how about the 2 PVC existing on the Serial S1/0.1.

Documentation ref will also be helpful.

Cheers!
Ravi
Average Rating: 0 (0 Votes)
Outline View
250 - 749vmiller
Bandwidth values for physical interfaces are set at statrup time (based
on the hardware)

for subinterfaces (logical) youset it yourself.
Average Rating: 0 (0 Votes)
Average Rating: 0 (0 Votes)
250 - 749vmiller
There are default bandwidth definitions for all interfaces, its nothing you set. For serial, the default is t-1 speeds

bandwidth

To set a bandwidth value for an interface, use the bandwidth interface configuration command. Use theno form of this command to restore the default values.
bandwidth kilobitsno  bandwidth

Syntax Description

#
kilobits
#
Intended bandwidth in kilobits per  second. For a full bandwidth DS3, enter the value 44736.

Default

Default bandwidth values are set during startup and can be  displayed with the EXEC command show interfaces.


Its an old reference.
Average Rating: 0 (0 Votes)