Locations of visitors to this page Perfect dream will never let you sleep in peace...untill you make it real: March 2011

Tuesday, March 29, 2011

EIGRP Metrics


EIGRP uses these scaled values to determine the total metric to the network:
  • metric = [K1 * bandwidth + (K2 * bandwidth) / (256 - load) + K3 * delay] * [K5 / (reliability + K4)]
Note: These K values should be used after careful planning. Mismatched K values prevent a neighbor relationship from being built, which can cause your network to fail to converge.
Note: If K5 = 0, the formula reduces to Metric = [k1 * bandwidth + (k2 * bandwidth)/(256 - load) + k3 * delay].
The default values for K are:
  • K1 = 1
  • K2 = 0
  • K3 = 1
  • K4 = 0
  • K5 = 0

    No MTU here :-(

Eigrp packet types study


Monday, March 28, 2011

EIGRP packet

This link explains the packets of the EIGRP if you are intrested.

http://www.rhyshaden.com/eigrp.htm

passive interface

i wanted to check what exactly happens to the eigrp packets sent from R2 when the s1/0 of the R1 is made passive.

R1

!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
 ip ospf network point-to-point
!

!
interface Serial1/0
 ip address 10.10.10.1 255.255.255.0
 serial restart-delay 0
!

!
router eigrp 10
 passive-interface Serial1/0
 network 10.10.10.0 0.0.0.255
 network 192.168.1.0
 distribute-list 20 out Serial1/0
 auto-summary
!
access-list 20 permit 192.168.1.0 0.0.0.255
access-list 20 deny   any
access-list 20 permit any
!

Here is the result on R1 and even though the R2 is sending the hello packets, it is never replied. Its sending the hello packets only on loop back.


Router#
*Mar  1 00:23:38.323: EIGRP: Sending HELLO on Loopback1
*Mar  1 00:23:38.323:   AS 10, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar  1 00:23:38.327: EIGRP: Received HELLO on Loopback1 nbr 192.168.1.1
*Mar  1 00:23:38.327:   AS 10, Flags 0x0, Seq 0/0 idbQ 0/0
*Mar  1 00:23:38.331: EIGRP: Packet from ourselves ignored
Router#
*Mar  1 00:23:42.919: EIGRP: Sending HELLO on Loopback1
*Mar  1 00:23:42.919:   AS 10, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar  1 00:23:42.923: EIGRP: Received HELLO on Loopback1 nbr 192.168.1.1
*Mar  1 00:23:42.923:   AS 10, Flags 0x0, Seq 0/0 idbQ 0/0
*Mar  1 00:23:42.927: EIGRP: Packet from ourselves ignored
Router#
*Mar  1 00:23:47.587: EIGRP: Sending HELLO on Loopback1
*Mar  1 00:23:47.587:   AS 10, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar  1 00:23:47.591: EIGRP: Received HELLO on Loopback1 nbr 192.168.1.1
*Mar  1 00:23:47.591:   AS 10, Flags 0x0, Seq 0/0 idbQ 0/0
*Mar  1 00:23:47.595: EIGRP: Packet from ourselves ignored



Thursday, March 24, 2011

eigrp over nbma (router as FR switch)













FR Config:


!
                         frame-relay switching  ---->VV important
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1/1 201
 frame-relay route 103 interface Serial1/2 301
!
interface Serial1/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 201 interface Serial1/0 102
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 301 interface Serial1/0 103
!

Rest you can refer to
http://oneperfectcciedream.blogspot.com/2010/09/eigrp-over-nbma-networkhub-and-spoke.html

here is the scenario of ip default-network


ip default-network

i was having issue with ip default-network while advertising the default routes. I raised a ticket in the cisco forums and here is the reply. The candidate default was not getting tagged/flagged.


Hi All,

Routes with * i.e. Default route is stil not appearing. I think there is a config mistake...but could not find where

router eigrp 100
network 1.0.0.0
network 10.1.0.0 0.0.255.255
network 172.16.0.0
network 192.168.12.0
network 192.168.13.0
no auto-summary
!
ip http server
!
ip route 1.0.0.0 255.0.0.0 1.1.1.0        ----->ip default-network 1.1.1.0
ip route 1.1.1.0 255.255.255.0 Null0

output::

C    192.168.12.0/24 is directly connected, Serial1/0
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
S       1.1.1.0/24 is directly connected, Null0
S       1.0.0.0/8 [1/0] via 1.1.1.0
C    192.168.13.0/24 is directly connected, Serial1/1
D    192.168.24.0/24 [90/2172416] via 192.168.12.2, 00:25:44, Serial1/0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.9.0 is directly connected, Loopback9
C       172.16.10.0 is directly connected, Loopback10
C       172.16.11.0 is directly connected, Loopback11
     10.0.0.0/24 is subnetted, 8 subnets
C       10.1.8.0 is directly connected, Loopback8
C       10.1.3.0 is directly connected, Loopback3
C       10.1.2.0 is directly connected, Loopback2
C       10.1.1.0 is directly connected, Loopback1
C       10.1.7.0 is directly connected, Loopback7
C       10.1.6.0 is directly connected, Loopback6
C       10.1.5.0 is directly connected, Loopback5
C       10.1.4.0 is directly connected, Loopback4
D    192.168.34.0/24 [90/2681856] via 192.168.13.2, 00:25:45, Serial1/1
D    192.168.0.0/24 [90/2297856] via 192.168.12.2, 00:25:45, Serial1/0

Any reason why its not cadidate default route.

Any assistance will be appreciated.

Cheers!
Ravi
Average Rating: 5 (1 Votes)
Outline View
17,500 - 24,999HALL OF FAME Founding member 2010Paolo Bevilacqua
1. Jan 31, 2011 11:35 AM  in response to: ravindra Krishna
Re: ip default-network is not working
Already replied in another thread, please avoid opening duplicates.
Average Rating: 0 (0 Votes)
Average Rating: 0 (0 Votes)
250 - 749vmiller
3. Jan 31, 2011 2:39 PM  in response to: ravindra Krishna
Re: ip default-network is not working
Average Rating: 0 (0 Votes)
10,000 - 17,499HALL OF FAME Founding member 2010Richard Burts
4. Feb 1, 2011 1:02 AM  in response to: vmiller
Re: ip default-network is not working
Ravi

Assuming that your config has this command to specify the default network "ip default-network 1.1.1.0" then the biggest problem is that you have violated one of the basic requirements of default network. The default network should be a classful network (class A or B or C) and not a subnet that is known somewhere is the network. But you have given a subnet value.

I believe that there is also an issue in the way that EIGRP processes your intended default network. The purpose of having a default network/gateway of last resort is to advertise to other EIGRP neighbors that they should forward to you their traffic for unknown destinations because you can forward it. But your router learns the route as a discard route to null 0.

There are better ways to get EIGRP to advertise a default route. You could use the EIGRP summary address command on interfaces to have EIGRP advertise a default route out those interfaces. Or you could configure a static default route and redistribute the static into EIGRP.

HTH

Rick



And in all it got resolved