Locations of visitors to this page Perfect dream will never let you sleep in peace...untill you make it real: September 2010

Tuesday, September 21, 2010

eigrp over nbma network(hub and spoke)



R1
=====

!
interface Loopback1
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
!
router eigrp 1
 network 172.16.1.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end



r2
==============

!
interface Loopback1
 ip address 172.16.2.1 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 201 broadcast
 frame-relay map ip 192.168.1.3 201 broadcast
!
router eigrp 1
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end



r3
=========
interface Loopback1
 ip address 172.16.3.1 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 301 broadcast
 frame-relay map ip 192.168.1.2 301 broadcast
!
router eigrp 1
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end

no ip split-horizon

I was not able to set up eigrp in hub and spoke scenario....

no ip split-horizon eigrp 1

is not working...so i need to work on gns3

Trip extended

seems trip will be extended....now its been very long I have stepped out of cisco dream....well daymares started to appear while work.

Lets start it again with a lil eigrp and ospf

i have save an eigrp lab with IP address already store. All I need to do is enable FR and eigrp

I will paste the config once I am done with the lab

Sunday, September 19, 2010

Immersed

Since Friday...I have either studied lil or nothing. For todays I spend my time with my family. I will not be here for 2 weeks. My next trip is scheduled on 23rd for KSA. I am trying to complete my KRA at work. I will have redirect the funds for my examination.  :-)

Wednesday, September 15, 2010

Day 12: OSPF

Start of OSPF

I tried 4 area network...dropped to 3...now i can populate routes....ospf is vast...good...i am lil worried about my progress....sat and sun are near....but I need to complete my KRA at job. May be I will work late on friday completing all docs and i need to prepare some presentations...just done with  Nigeria trip...now KSA is scheduled by end of this month.

once the trip is over I will have again concentrate more on studies...i need to complete my CCNP routing as soon as possible now.

Tuesday, September 14, 2010

Trick to keep CPU utilization low in GNS3

don't let your routers go back to idle state

1> get an idle PC value

2> to make sure..it does not use CPU utilization suddenly in middle of configuration.

>en
# conf t
# line console 0
# no exec-timeout

day 11: Complete

Its been eleven days.....very less time and more to learn...

Network will be summarized when there is a major change in the subnet....in the earlier diagram...mojority if the network was in 10.0.0.0/8 subnet and hence it was not being summarized......but there is a change in the subnet of the 172 to 10 and hence routes have been summarized to classful subnet


Amazing......came to know after reading white paper from Cisco and Cisco blog

http://www.cisco.com

Monday, September 13, 2010

oh god back to square one


R0
====
interface Serial0/3/0
ip address 10.1.24.1 255.255.255.252
clock rate 64000
!
interface Serial0/3/1
ip address 10.1.34.1 255.255.255.252
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router eigrp 25
network 10.1.34.1 0.0.0.0
network 10.1.24.1 0.0.0.0
network 172.16.0.0
auto-summary

R1
=====
interface FastEthernet0/0
ip address 10.1.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/3/0
ip address 10.1.34.2 255.255.255.252
!
router eigrp 25
network 10.1.34.2 0.0.0.0
network 10.1.2.0 0.0.0.255
auto-summary

R2
======

interface FastEthernet0/0
ip address 10.1.2.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.25.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/3/0
ip address 10.1.24.2 255.255.255.252
!
router eigrp 25
network 10.1.24.2 0.0.0.0
network 10.1.2.0 0.0.0.255
auto-summary
!


Now thank you for your patience since you are reading this now after going through all my network diagram.

R2 Routes
========
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.1.2.0/24 is directly connected, FastEthernet0/0
C       10.1.24.0/30 is directly connected, Serial0/3/0
C       10.1.25.0/24 is directly connected, FastEthernet0/1
D       10.1.34.0/30 [90/2172416] via 10.1.2.1, 00:24:47, FastEthernet0/0  <-------why this is not 10.0.0.0/8
D    172.16.0.0/16 [90/2297856] via 10.1.24.1, 00:21:11, Serial0/3/0

Again a major set back in understanding the network command....God! this is getting more complex. And I am really not able to understand this network command...lets search for better docs on this....need major article on this.



little knowledge is very dangerous

I understand the meaning of this proverb now. A single mistake done with lack of knowledge may get your whole network done.

I have to be more careful. In labs we are eligible to do anything...a best place to learn a car is in an open area. This makes sure that no one is hurt. If we try learning on a busy road...chances are more that you make a everyone to shout over you because you cause traffic Jams.

So thats the reason, I stopped at network command. I just joined two routers configured Eigrp with loop backs.
1> changed loops backs..checked routes
2> changed networks ...checked routes
3> changed loop backs with no auto-summary
4> with route summarization.

I took me very long time...almost 5 days after doing heavy testing...to understand the network command.

Sunday, September 12, 2010

The network command


This is a simple logic that was simple to understand but it took me almost 5 days to understand.
The network command in EIGRP is very brain chewing command for me.

I wanted to understand how it works exactly. Below is my explaination.

Above is my network diagram.

Below are the commands the I used on R1
# router eigrp 1
# network 192.168.1.0------>A
# network .............. ------->B

A> By default the eigrp auto summarizes to classful network. Hence it will always be 192.168.1.0/24 in the routing table.

B>

Case I> Check all WC carefully
network 10.0.0.0
or
network 10.10.0.0 0.0.255.255
or
network 10.10.1.1 0.0.0.0
or
network 10.10.0.0 0.0.3.255

will all give same result i.e. in the routing table of R0 you will always find 10.0.0.0/8
since it will automatically summarize to classful subnet

With no auto-summary you are disabling the auto summarization to classful subnets

Case II> This is most interesting

I have one more network in the R1 side 10.10.222.0/24 network
a> network 10.0.0.0 or network 10.10.0.0 0.0.255.255 will allow us to ping 10.10.1.1 from R1

b> if I use
#network 10.10.0.0 0.0.3.255
#no auto-summary

then this command will exclude the 10.10.222.0 subnet from my network command and pinging it will not be possible from R1.

============================================

Conclusion :
a> network command helps to determine what networks are eligible to be advertised
b> better always use no auto-summary
c> then sends advertisement on 224.0.0.10

Need expert comments on this

Decided to follow below method for my ccnp

it was getting difficult to understand the things and how they work with out doing labs. For doing labs CBT is best to understand basic underlying concepts. So i decided to go through following process

1> Go through CBT-understand basic concepts-do labs along Jeremy
3> Note down all the problems/queries you have faced.
2> Once done with all the videos come to CCNP official Guide...read every page.... every single line has meaning and it opens many unsolved.

lets check this way..if it doesnt work I have to find a new way for switching or read the ccnp routing again

I am positive this is going to work reason being...
1> with jeremy you will understand how things work basically and come out with a conclusion
2> with cisco guide you will co-relate your conclusion with how exactly the cisco things work.

Hope this works for me!

Let me know how your approach was

http://www.cisco.com
http://www.careercert.info/

Saturday, September 11, 2010

God! its not so easy

I was watching and hearing Jeremy talking about EIGRP. I thought that is all!

I got Cisco 642-902 official exam guide. Its far more than what I exactly thought it would be. After going through "Do you already know Quiz" I came to know there is much more to learn that what I actually thought. The questions simply made me realize that

buddy, what you know is a little and what you need to know is more.

:-)

its better to know it at early stages than wondering later. I think this is going to be tough Journey

Best of luck

lets get started again with EIGRP ;-)

https://learningnetwork.cisco.com/docs/DOC-6568

Network Command

Network command is haunting me now. I think I should give it some time to understand. I will get back in deep after a while. Lets go ahead with EIGRP over FrameRelay.

I like configuring frame relay. :-)

Thursday, September 9, 2010

tired

I am really tired today after the night shift. I need some rest.

Wednesday, September 8, 2010

multipoint frame-relay- Hub and Spoke with RIP

ah I took me some time to figure out how to configure multipoint frame-realy in hub and spoke network with RIP

hope this helps for you guys
                         <-------r2
r1---->FR cloud
                        <-------r3


r1 is my hub
===========================

!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!

interface Serial0/3/0
 ip address 192.168.1.1 255.255.255.0
 no ip split-horizon          ---->this command really killed me....this stops split horizon
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
 clock rate 64000
!

router rip
 network 172.16.0.0
 network 192.168.1.0
!
=================================================

r2 is my spoke
=====================================================

!
interface FastEthernet0/0
 ip address 172.17.1.1 255.255.255.0
 duplex auto
 speed auto
!

interface Serial0/3/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 201 broadcast
 frame-relay map ip 192.168.1.2 201 broadcast
 clock rate 64000
!

router rip
 network 172.17.0.0
 network 192.168.1.0
!
========================================

r3 is my spoke
====================================

!
interface FastEthernet0/0
 ip address 172.18.1.1 255.255.255.0
 duplex auto
 speed auto
!

interface Serial0/3/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 301 broadcast
 frame-relay map ip 192.168.1.2 301 broadcast
 clock rate 64000
!

router rip
 network 172.18.0.0
 network 192.168.1.0
!

eigrp auto-summarization

This is cool..it took few minutes to understand this concept

(f0/0 172.16.0.0/255.255.248.0)  R1<---->R2   (f0/0 172.18.0.0/255.255.248.0)

By default EIGRP auto summarizes.

# network 172.16.0.0 0.0.7.255

I thought it should advertise same to the other router as it auto summarizes...but what I saw is it auto summarizes to 172.16.0.0/16 in R2....hmmm

So By Default it auto summarizes to classfull subnet

If I choose no auto-summary then it will populate each network i.e. from 172.16.0.0 to172.16.7.0

But I wanted to summarize routes to 172.16.0.0/21

after lil research I found

# int f0/0
# ip summary-address eigrp 12 172.16.0.0 255.255.248.0

aha...now i can see summarized route

Its an amazing journey...each day a new concept...i like it

The network command

post has ben deleted as this was completely wrong

Tuesday, September 7, 2010

working with GNS3

working with GNS3

it was a great deal..optimizing the cpu utilization and making it to use minimum cpu
here is what I have done
1> got the gns3 from website and also Cisco image unpacker 0.1 binary for Windows from gns3 website itself
2> downloaded the cisco 2621 IOS from torrent-->by default it uses only 64 MB very less again
3> unzipped the cisco IOS with unpacker 0.1 ---this will ensure to utilize less CPU as it does have to waste cpu utilization in unzipping each time.
4> used idle PC value
5> Used BES software and reduced the cpu utilization further to 33%

now even after running 5 *2621 my cpu utilizaion is not more than 40%


Also i prefer using secure crt as it was fun working with tabs...while putty will open new console windows for every appliance.

C:\progra~1\vandyk~1\SecureCRT\SecureCRT.EXE /script c:\progra~1\gns3\securecrt.vbs /arg %d /T /telnet %h %p

Please change your path settings accordingly. However, the above is default.

Now In the mean time I got my EIGRP configured.

thanks to http://www.careercert.info/ where i have downloaded all study material to get started with ccnp

Sunday, September 5, 2010

lets do something proactive

in the mean time i practiced my ospf (single area) and multipoint and p2p FR again...just to make sure I am confident in configuring and understand them better

Saturday, September 4, 2010

speed up

nw my speed is back 2 normal ....now 100mb takes 6 mins to download......8 more videos to download

Found CCNP Material

http://www.4shared.com/dir/Qe_dUXbB/CBTn_ROUTE.html#

My download BW is very less today. I called up my ISP they gave me ticket number. ISP guy came in the evening checked that my download speed is only 24kbps but according to my plan it should be downloading at 172-176 Kbps.

I am done downloading 4 parts. In the mean while i searched for some e-books and some blogs to keep my spirit up.

In the evening we went out to have our dinner. Now since I am back.. started downloading again.

i am ready for ccna

by start of next month i will have enough resources to give my ccna
till then i will have to start  collecting my ccnp material and start studying for ccnp..lets do it now

day 2: are you ready for ccna?

Friday, September 3, 2010

day 1 : progress

in this scenario i have configured rip over frame relay

Perfect dream will never let you sleep in peace

Lets make the dream real of becoming a CCIE. I wish to complete my CCIE by Aug next year. Lets start it with CCNA. Each day I will try near my goal. Lets start it today.