Locations of visitors to this page Perfect dream will never let you sleep in peace...untill you make it real: BGP_IBGP_EBGP_Neighbour forming ----->Fun

Monday, February 14, 2011

BGP_IBGP_EBGP_Neighbour forming ----->Fun

Here is the BGP topology i have created. It was quite challenging. My GNS3 is causing the CPU 100% as soon as I run 5 routers with BGP. Super process intensive. I wonder why firewalls and UTM are being used for the BGP.

Here is the result you should finally have  on router 5:
Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/129] via 10.10.5.1, 00:18:09, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [200/0] via 1.1.1.1, 00:00:17
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback5
     172.10.0.0/24 is subnetted, 1 subnets
B       172.10.0.0 [200/0] via 1.1.1.1, 00:00:17
     10.0.0.0/24 is subnetted, 4 subnets
B       10.10.1.0 [200/0] via 1.1.1.1, 00:00:17
B       10.10.2.0 [200/0] via 1.1.1.1, 00:00:18
O       10.10.3.0 [110/128] via 10.10.5.1, 00:18:09, Serial1/0
C       10.10.5.0 is directly connected, Serial1/0
B    200.10.30.0/24 [200/0] via 1.1.1.1, 00:00:20
B    200.10.10.0/24 [200/0] via 1.1.1.1, 00:00:20


=======================================================


R1
show ip route result:
    1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback1
     2.0.0.0/32 is subnetted, 1 subnets
S       2.2.2.2 [1/0] via 10.10.0.2
     3.0.0.0/32 is subnetted, 1 subnets
S       3.3.3.3 [1/0] via 10.10.2.2
                [1/0] via 10.10.1.2
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/129] via 10.10.3.2, 00:32:28, Serial1/3
     172.10.0.0/24 is subnetted, 1 subnets
B       172.10.0.0 [20/0] via 3.3.3.3, 00:26:29
     10.0.0.0/24 is subnetted, 5 subnets
C       10.10.0.0 is directly connected, Serial1/0
C       10.10.1.0 is directly connected, Serial1/1
C       10.10.2.0 is directly connected, Serial1/2
C       10.10.3.0 is directly connected, Serial1/3
O       10.10.5.0 [110/128] via 10.10.3.2, 00:32:32, Serial1/3
B    200.10.30.0/24 [20/0] via 2.2.2.2, 00:37:07
B    200.10.10.0/24 [20/0] via 2.2.2.2, 00:37:21

!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.10.0.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 10.10.1.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 10.10.2.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/3
 ip address 10.10.3.1 255.255.255.0
 serial restart-delay 0
!
router ospf 1000
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.3.0 0.0.0.255 area 0
!
router bgp 1000
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 2000
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback1
 neighbor 3.3.3.3 remote-as 3000
 neighbor 3.3.3.3 ebgp-multihop 2
 neighbor 3.3.3.3 update-source Loopback1
 neighbor 5.5.5.5 remote-as 1000
 neighbor 5.5.5.5 update-source Loopback1
 neighbor 5.5.5.5 next-hop-self
 no auto-summary
!
ip http server
!
ip route 2.2.2.2 255.255.255.255 10.10.0.2
ip route 3.3.3.3 255.255.255.255 10.10.1.2
ip route 3.3.3.3 255.255.255.255 10.10.2.2
========================================
r2

!
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
 ip address 200.10.30.1 255.255.255.0
!
interface Loopback4
 ip address 200.10.40.1 255.255.255.0
!
interface Loopback10
 ip address 200.10.10.1 255.255.255.0
!
interface Loopback11
 ip address 200.10.20.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.10.0.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 2000
 no synchronization
 bgp log-neighbor-changes
 network 200.10.10.0
 network 200.10.30.0
 neighbor 1.1.1.1 remote-as 1000
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback2
 no auto-summary
!         
ip http server
!
ip route 1.1.1.1 255.255.255.255 10.10.0.1
!

=============================================

r3

!
interface Loopback3
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback10
 ip address 172.10.0.1 255.255.255.0
!
interface Loopback11
 ip address 172.10.1.1 255.255.255.0
!
interface Loopback12
 ip address 172.10.2.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.10.1.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 10.10.2.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 3000
 no synchronization
 bgp log-neighbor-changes
 redistribute connected route-map fix
 neighbor 1.1.1.1 remote-as 1000
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback3
 no auto-summary
!
ip http server
!
ip route 1.1.1.1 255.255.255.255 10.10.1.1
ip route 1.1.1.1 255.255.255.255 10.10.2.1
!         
!
access-list 10 deny   172.10.1.0 0.0.0.255
access-list 10 deny   172.10.2.0 0.0.0.255
access-list 10 permit any
!
route-map fix permit 10
 match ip address 10
!
!
!
========================================================
r4

!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.10.3.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 10.10.5.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1000
 log-adjacency-changes
 network 10.10.3.0 0.0.0.255 area 0
 network 10.10.5.0 0.0.0.255 area 0
!
ip http server
!
=================================
r5


!
interface Loopback5
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.10.5.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1000
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 10.10.5.0 0.0.0.255 area 0
!
router bgp 1000
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1000
 neighbor 1.1.1.1 update-source Loopback5
 no auto-summary
!
ip http server
!
======================================================
r1 sh ip bgp


Router#sh ip bgp
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 3.3.3.3/32       3.3.3.3                  0             0 3000 ?
r> 10.10.1.0/24     3.3.3.3                  0             0 3000 ?
r> 10.10.2.0/24     3.3.3.3                  0             0 3000 ?
*> 172.10.0.0/24    3.3.3.3                  0             0 3000 ?
*> 200.10.10.0      2.2.2.2                  0             0 2000 i
*> 200.10.30.0      2.2.2.2                  0             0 2000 i














No comments:

Post a Comment