Locations of visitors to this page Perfect dream will never let you sleep in peace...untill you make it real: EIGRP/ OSPF /Route Summarization/ Default Routes/ Route-maps/ Tags---> Great Fun

Wednesday, February 2, 2011

EIGRP/ OSPF /Route Summarization/ Default Routes/ Route-maps/ Tags---> Great Fun



Ah this was great! 45 mins of pain:
Eigrp+ospf+route redistribution+route-maps+Default routes+Tags--->Fun

As promised, I will keep all the scenarios with config

R1-->networks 10.1.0.0/21 + 10.1.8.0/24 + 192.168.12.0/24 + 192.168.13.0/24 +eigrp + no auto+ route summarization on s1/1
R2-->net 1.1.1.0/24(lo +public connection+default route to null 0) + 192.168.24.0/24 + 192.168.12/0 + eigrp + Eigrp Summarization on s1/1
R3-->networks 192.168.13.0/24 + 192.168.34.0/24
R4---> net 192.168.24.0/24 + 192.168.34.0/24 + Redistribution to ospf area 0 on s1/2 -->172.16.16.0/24 + default route of eigrp should be having tag  and metric-type e2 and rest should have tag and metric type e1. Do not allow 10.1.8.0/24 in the ospf. In ospf the default route should be the same as default route of the eigrp.

No auto summary in eigrp

R1
=================
!
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.1.4.1 255.255.255.0
!
interface Loopback5
 ip address 10.1.5.1 255.255.255.0
!
interface Loopback6
 ip address 10.1.6.1 255.255.255.0
!
interface Loopback7
 ip address 10.1.7.1 255.255.255.0
!
interface Loopback8
 ip address 10.1.8.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 192.168.13.1 255.255.255.0
 ip summary-address eigrp 100 10.1.0.0 255.255.248.0 5
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 network 10.1.0.0 0.0.255.255
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary
!

=================

R2


interface Loopback100
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 192.168.24.1 255.255.255.0
 ip summary-address eigrp 100 10.1.0.0 255.255.248.0 5
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 network 1.1.1.0 0.0.0.255
 network 192.168.12.0
 network 192.168.24.0
 auto-summary
!
ip http server
!
ip default-network 1.0.0.0
ip route 1.1.1.0 255.255.255.0 Null0
!
===========================================
R3

!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.13.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 192.168.34.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 network 192.168.13.0
 network 192.168.34.0
 auto-summary
!

=====================================
R4


!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.24.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 192.168.34.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 172.16.16.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 network 192.168.24.0
 network 192.168.34.0
 auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map eigrp2ospf
 network 172.16.16.0 0.0.0.255 area 0
 default-information originate
!
ip http server
!
!
!
access-list 2 permit 192.168.34.0 0.0.0.255
access-list 2 permit 192.168.13.0 0.0.0.255
access-list 2 permit 10.1.8.0 0.0.0.255
!
route-map eigrp2ospf permit 10
 match ip address 1
 set metric-type type-1
 set tag 10
!
route-map eigrp2ospf permit 20
 match ip address 2
 set tag 20
!
=======================================
R5

!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.16.16.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 log-adjacency-changes
 network 172.16.16.0 0.0.0.255 area 0
!




No comments:

Post a Comment